Computer Network Assignment

19-10-16 Rochio Varela 0 comment

TASK 1

1.1 Draw a complete LAN design including servers, connecting devices, workstations, peripherals, etc. for the above scenario. Please include the configuration scripts in the appendix.

Computer Network Assignment, programming assignment help

We have design LAN diagram with the help of cisco packet tracer and find the below mention

Step by step process of implementation on network security for LAN

First we will configure core switch and implementing all technology

  1. Configure host name of switch , router
  2. We can create new four VLAN as per our senior , Customer Service VLAN , Accounts/Finance VLAN , Library VLAN and server VLAN in  switch
  3. After that we can configure VTP domain ( virtual trunking protocol ) in switch
  4. We can configure STP in core switch so we can protract for network loop or loop free network
  5. All access switch port (PC connected )   should be in access mode

Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help

VLAN Trunking Protocol ( VTP )

We can configure VTP domain as server  in switch or  in other word VTP is organized into management domains, or areas with common VLAN requirements. A switch can belong to only one VTP domain, in addition to sharing VLAN information with other switches in the domain.

VTP servers have full control over VLAN creation and modification for their domains. All VTP information is advertised to other switches in the domain, while all received VTP information is synchronized with the other switches. By default, a switch is in VTP server mode. Note that each VTP domain must have at least one server so that VLANs can be created, modified, or deleted, and VLAN information can be propagated.

CD-NEW-HO-COR-SW#sh vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally: 1005

Number of existing VLANs        : 5

VTP Operating Mode              : Server

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Local updater ID is 0.0.0.0 (no valid interface found)

CD-NEW-HO-COR-SW# 

1.2 Prepare a list of IP addresses, subnet IDs, Broadcast IDs for each department, Justify your choice for chosen techniques (VLSM or others)

The college will be using private IP address 192.168.0.0/16 within LAN and  we will user same ip pool for accessing outside network or WAN network  devices.

Read our experts advice : Computer network assignment help
Subnet allocation Site Bit
192.168.0.0

Start Host 192.168.0.1

End Hot 192.168.1.255

Subnet Mask 255.255.254.0

Edinburgh 192.168.0.0/23
192.168.2.0

Start Host 192.168.2.1

End Hot 192.168.3.255

Subnet Mask 255.255.254.0

Birmingham 192.168.2.0/23
192.168.4.0

Start Host 192.168.4.1

End Hot 192.168.5.255

Subnet Mask 255.255.254.0

Liverpool 192.168.4.0/23
192.168.6.0

Start Host 192.168.6.1

End Hot 192.168.7.255

Subnet Mask 255.255.254.0

Manchester 192.168.6.0/23
192.168.8.0

Start Host 192.168.8.1

End Hot 192.168.9.255

Subnet Mask 255.255.254.0

Glasgow 192.168.8.0/23
192.168.10.0

Start Host 192.168.10.1

End Hot 192.168.11.255

Subnet Mask 255.255.254.0

NEW HO in CP 192.168.10.0/23

 

IP Address and VLSM

 

The term variable-length subnet mask (VLSM) describes a single Class C network in network which more than one subnet mask is used. Whenever implement a VLSM design. If you understood the previous paragraph, you already understand the concepts behind VLSM. Planning, implementing, and operating a network that uses VLSM requires a full, comfortable understanding of subnetting.

For Example

Now we are configure new head office in Central London with subnet mask 192.168.10.0/23

192.168.10.0 /23

Start Host 192.168.10.1

End Hot 192.168.11.255

Subnet Mask 255.255.254.0

Library department 

Address:   192.168.10.0

Subnet mask:   255.255.255.0 = 24

Wildcard:  0.0.0.255

=>

Network:   192.168.10.0/24

Broadcast: 192.168.10.255

Starting Host:   192.168.10.1

End Host:   192.168.10.254

Hosts: 254

Finance department 

Address:   192.168.11.0

Subnet mask:   255.255.255.192 = 26

Wildcard:  0.0.0.63

=>

Network:   192.168.11.0/26

Broadcast: 192.168.11.63

Starting Host:   192.168.11.1

End Host:   192.168.11.62

Hosts: 62 

Customer Service: 

Address:   192.168.11.64

Subnet mask:   255.255.255.192 = 26

Wildcard:  0.0.0.63

=>

Network:   192.168.11.64/26

Broadcast: 192.168.11.127

Starting Host:   192.168.11.65

End Host:   192.168.11.126

Hosts/Net: 62 

Server ip address  :

Address:   192.168.11.128

Subnet mask:   255.255.255.192 = 26

Wildcard:  0.0.0.63

=>

Network:   192.168.11.128/26

Broadcast: 192.168.11.191

Starting Host:   192.168.11.129

End Host:   192.168.11.190

Hosts: 62

Finance department IP address list-: In finance department we have required 34 IP addresses for Systems and one IP address for printer. So here we have created /26 series of IP address, each block contain 64 addresses there one IP address is used for gateway & one is used for broadcasting.

Work Station IP Address Subnet Mask Broadcast ID
PC1 192.168.11.10 255.255.255.192 192.168.11.63
PC2 192.168.11.11 255.255.255.192 192.168.11.63
PC3 192.168.11.12 255.255.255.192 192.168.11.63
PC34 192.168.11.44

 

255.255.255.192 192.168.11.63
Printer 192.168.11.50 255.255.255.192 192.168.11.63

Customer Service have only five work station. 192.168.11.64/26

Work Station IP Address Subnet Mask Broadcast ID
PC1 192.168.11.70 255.255.255.192 192.168.11.127
PC2 192.168.11.71 255.255.255.192 192.168.11.127
PC3 192.168.11.72 255.255.255.192 192.168.11.127
PC4 192.168.11.73 255.255.255.192 192.168.11.127
PC5 192.168.11.74 255.255.255.192 192.168.11.127

 

Library department -: 200 workstation are installed in Library so we require /24 subnet IP address. 192.168.10.0/24

Work Station IP Address Subnet Mask Broadcast ID
PC1 192.168.10.10 255.255.255.0 192.168.10.255
PC2 192.168.10.11 255.255.255.0 192.168.10.255
PC3 192.168.10.12 255.255.255.0 192.168.10.255
PC4 192.168.10.13 255.255.255.0 192.168.10.255
PC5 192.168.10.14 255.255.255.0 192.168.10.255
PC10 192.168.10.19 255.255.255.0 192.168.10.255
PC200 192.168.10.209 255.255.255.0 192.168.10.255
Printer 1 192.168.10.220 255.255.255.0 192.168.10.255
Printer 2 192.168.10.221 255.255.255.0 192.168.10.255

 

Server ip address  :  192.168.11.128/26     File Server, Web Server, Domain Controller

 

Server ip IP Address Subnet Mask Broadcast ID
Web Services 192.168.11.140 255.255.255.192 192.168.11.191
File Server 192.168.10.141 255.255.255.192 192.168.11.191

 

TASK 2

2.1 Create a performance baseline for the above company network and evaluate the designed LAN

Creating the baseline of LAN network design in Dot.edu College we have to pull the performance data of college network traffic, bandwidth utilization and errors.  We know there was no change done after setup. We need to pull daily or weekly performance reports from monitoring tools  PRGT and EMC Smart so that we check how much bandwidth has been used during the working hours or day  and also we check on other  monitoring tool whether we get any errors on the interfaces or not. All access port where user systems are connected; those were put in monitoring tool which helps us to identify how much data have been used. Network devices which we configured during the time of setup, are these using all features of new technology. Security policy which we applied on network LAN segment like mac binding or port security policy are those working or not. We ping router IP from  switch continuously to check latency and drops. We also keep checking ports and make sure that ports are proper VLAN according to department.

Below are the baseline parameter which was configured.

  • Reviewing the applied policy
  • Bandwidth thresholds on monitoring tool, in case of crossing, it generates the alerts.
  • CPU and Memory utilization baseline.

2.2 There are many tools available in the market to monitor the performance of a network, choose one and produce a performance monitoring report for your network.

Dot.edu College we are using two monitoring tools PRTG, EMC smart. Monitoring tools are the key for network stability and security. EMC smart software helps us to identify any link failure and device down. PRTG checks the devices, link performance. If any abnormality occurs on the network, proactively send the alert. It helps us to the action in advance so that we can take quick action. Below are the key advantages of the monitoring tools.

  • We can also monitor health of the servers
  • It auto sends alerts of link failure and device failure.
  • It provides real time monitoring and also provide historical data
  • If any logs generates on the devices, it also send informal alerts.

TASK 3

3.1. Use a network simulator to simulate the designed LAN including the following

Building and configuration of devices and services within the LAN and Implementation of specialised configuration and security mechanisms within the LAN

Computer Network Assignment, programming assignment help

I am configuring New HO location in Central London so first I will configure Router and connected with Core switch mention below.

We have configure host name of router with command

Computer Network Assignment, programming assignment help

router#configure terminal

router(config)#hostname CD-NEW-HO-RT

Computer Network Assignment, programming assignment help

We are configuring new HO location LAN segment  so first we will configure Core switch and  we can create 4  VLAN in core switch mention below .

Computer Network Assignment, programming assignment help

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)#vl

CD-NEW-HO-COR-SW(config)#vlan n

CD-NEW-HO-COR-SW(config)#vlan 10

CD-NEW-HO-COR-SW(config-vlan)#

%LINK-5-CHANGED: Interface Vlan10, changed state to up

CD-NEW-HO-COR-SW(config-vlan)#name Customer_Service

Computer Network Assignment, programming assignment help

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)#vlan

% Incomplete command.

CD-NEW-HO-COR-SW(config)#vlan 20

CD-NEW-HO-COR-SW(config-vlan)#name Accounts/Finance

CD-NEW-HO-COR-SW(config-vlan)#exit

Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help

CD-NEW-HO-COR-SW(config)#

CD-NEW-HO-COR-SW(config)#vlan 30

CD-NEW-HO-COR-SW(config-vlan)#name Library

CD-NEW-HO-COR-SW(config-vlan)#exit

CD-NEW-HO-COR-SW(config)#vlan 40

CD-NEW-HO-COR-SW(config-vlan)#name server

CD-NEW-HO-COR-SW(config-vlan)#exit

D-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)#interface vlan 10

CD-NEW-HO-COR-SW(config-if)#description << Customer_Service LAN >>

CD-NEW-HO-COR-SW(config-if)#ip address 192.168.11.65 255.255.255.192

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#exit

CD-NEW-HO-COR-SW(config)#exit

CD-NEW-HO-COR-SW#

Computer Network Assignment, programming assignment help

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)#interface vlan 10

CD-NEW-HO-COR-SW(config-if)#description << Customer_Service LAN >>

CD-NEW-HO-COR-SW(config-if)#ip address 192.168.11.65 255.255.255.192

CD-NEW-HO-COR-SW(config-if)#standby 10 ip 192.168.11.67

CD-NEW-HO-COR-SW(config-if)#standby 10 priority 150

CD-NEW-HO-COR-SW(config-if)#standby 10 preempt

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#interface Vlan20

CD-NEW-HO-COR-SW(config-if)# description *** Connected Accounts/Finance VLAN ***

CD-NEW-HO-COR-SW(config-if)# ip address 192.168.11.1  255.255.255.192

CD-NEW-HO-COR-SW(config-if)# standby 10 ip 192.168.11.3

CD-NEW-HO-COR-SW(config-if)# standby 10 priority 150

CD-NEW-HO-COR-SW(config-if)# standby 10 preempt

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#interface Vlan30

CD-NEW-HO-COR-SW(config-if)# description *** Connected Library  VLAN ***

CD-NEW-HO-COR-SW(config-if)# ip address 192.168.10.1  255.255.255.0

CD-NEW-HO-COR-SW(config-if)# standby 10 ip 192.168.10.3

CD-NEW-HO-COR-SW(config-if)# standby 10 priority 150

CD-NEW-HO-COR-SW(config-if)# standby 10 preempt

CD-NEW-HO-COR-SW(config-if)#

CD-NEW-HO-COR-SW(config-if)#interface Vlan40

CD-NEW-HO-COR-SW(config-if)# description *** Connected Web_Services VLAN ***

CD-NEW-HO-COR-SW(config-if)# ip address 192.168.11.129 255.255.255.192

CD-NEW-HO-COR-SW(config-if)# standby 10 ip 192.168.11.131

CD-NEW-HO-COR-SW(config-if)# standby 10 priority 150

CD-NEW-HO-COR-SW(config-if)# standby 10 preempt

CD-NEW-HO-COR-SW(config-if)#

%LINK-5-CHANGED: Interface Vlan20, changed state to up

%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINK-5-CHANGED: Interface Vlan40, changed state to up

CD-NEW-HO-COR-SW(config-if)#exit

CD-NEW-HO-COR-SW(config)#exit

CD-NEW-HO-COR-SW#

%SYS-5-CONFIG_I: Configured from console by console

CD-NEW-HO-COR-SW#

Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help Computer Network Assignment, programming assignment help

Read more about Website Design Assignment Help

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)# interface FastEthernet0/1

CD-NEW-HO-COR-SW(config-if)# description *** Connected to Access Switch ***

CD-NEW-HO-COR-SW(config-if)# switchport trunk encapsulation dot1q

CD-NEW-HO-COR-SW(config-if)# switchport trunk allowed vlan 10,20,30,40

CD-NEW-HO-COR-SW(config-if)# switchport mode trunk

CD-NEW-HO-COR-SW(config-if)# interface FastEthernet0/2

CD-NEW-HO-COR-SW(config-if)# description *** Connected to Access Switch ***

CD-NEW-HO-COR-SW(config-if)# switchport trunk encapsulation dot1q

CD-NEW-HO-COR-SW(config-if)# switchport trunk allowed vlan 10,20,30,40

CD-NEW-HO-COR-SW(config-if)# switchport mode trunk

CD-NEW-HO-COR-SW(config-if)# interface FastEthernet0/3

CD-NEW-HO-COR-SW(config-if)# description *** Connected to Access Switch ***

CD-NEW-HO-COR-SW(config-if)# switchport trunk encapsulation dot1q

CD-NEW-HO-COR-SW(config-if)# switchport trunk allowed vlan 10,20,30,40

CD-NEW-HO-COR-SW(config-if)# switchport mode trunk

CD-NEW-HO-COR-SW#sh spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol

  Bridge Identifier has priority of 32768, sysid 1, 0006.2A30.554E

  Configured hello time 2, max age 20, forward delay 15

  Current root has priority 32769

  Topology change flag not set, detected flag not set

  Number of topology changes 0 last change occurred 00:00:00 ago

                        from FastEthernet0/1

  Times:  hold 1, topology change 35, notification 2

                                hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0001 is designated   Port path cost 19, Port priority 128, Port Identifier 128.1

  Designated bridge has priority 32769, address 0006.2A30.554E

  Designated port id is 128.1, designated path cost 19

  Timers: message age 16, forward delay 0, hold 0

  Number of transitions to forwarding state: 1

  Link type is point-to-point by default

Read more about IT Network Project Assignment Help

Port 2 (FastEthernet0/2) of VLAN0001 is designated   Port path cost 19, Port priority 128, Port Identifier 128.2

  Designated bridge has priority 32769, address 0006.2A30.554E

  Designated port id is 128.2, designated path cost 19

  Timers: message age 16, forward delay 0, hold 0

  Number of transitions to forwarding state: 1

  Link type is point-to-point by default

We can configure DHCP so IP address will dynamically assign to end user

CD-NEW-HO-COR-SW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CD-NEW-HO-COR-SW(config)#

CD-NEW-HO-COR-SW(config)#

CD-NEW-HO-COR-SW(config)#

CD-NEW-HO-COR-SW(config)#ip dhcp pool Customer_Service

CD-NEW-HO-COR-SW(dhcp-config)#   network 192.168.11.70 255.255.255.192

CD-NEW-HO-COR-SW(dhcp-config)#   default-router 192.168.11.67

CD-NEW-HO-COR-SW(dhcp-config)#

CD-NEW-HO-COR-SW(dhcp-config)#ip dhcp pool Accounts/Finance

CD-NEW-HO-COR-SW(dhcp-config)#   network 192.168.11.10 255.255.255.192

CD-NEW-HO-COR-SW(dhcp-config)#   default-router 192.168.11.3

CD-NEW-HO-COR-SW(dhcp-config)#

CD-NEW-HO-COR-SW(dhcp-config)#ip dhcp pool Library

CD-NEW-HO-COR-SW(dhcp-config)#   network 192.168.10.10 255.255.255.0

CD-NEW-HO-COR-SW(dhcp-config)#   default-router 192.168.10.3

CD-NEW-HO-COR-SW(dhcp-config)#

CD-NEW-HO-COR-SW(dhcp-config)#

Read more about Computer Programming Assignment Help

REFERENCES

  • Carol, X, Computer‐mediated communication and social networking tools at work.Information Technology and People. 26 (2). PP.172 – 190.
  • Morten H. A.,2011, Sensemaking in Networks: Using Network Pictures to Understand Network Dynamics, in Roger Baxter, Arch G. Woodside (ed.) Internet Networks: Theory, Strategy, and Behavior.17. Emerald Group Publishing Limited. PP.1 – 197.
  • Jason B. F. And Thomas L. M., 2012. Tools for interdisciplinary design of pervasive computing. International Journal of Pervasive Computing and Communications. 8. PP.112 – 132.
  • Sheynblat, L., Krasner, N. F., U.S. Patent No. 6,677,894. Washington, DC: U.S. Patent and Trademark Office.

Programming Assignments Help is the best assignment help provider in the United Kingdom. Our online assignment writing help UK is especially dedicated for the students studying in all UK colleges and universities. Submit assignment to get the best quality assignment help